2017 June Release

Unterstützte Plattformen und MinimalkonfigurationPermanenter Link zu dieser Überschrift

Für die Verwendung von Fabasoft app.test 2017 zur Automatisierung von Tests für Fabasoft Folio bzw. für die Fabasoft eGov-Suite werden folgende Versionen unterstützt:

  • Fabasoft Folio 2012 bis 2016
  • Versionen der Fabasoft eGov-Suite, die auf den oben genannten Versionen von Fabasoft Folio basieren

„Microsoft Windows“-SystemumgebungPermanenter Link zu dieser Überschrift

Fabasoft app.test Studio und Fabasoft app.test Agent

Betriebssystem

Prozessorarchitektur

Microsoft Windows 7 Enterprise SP1
oder
Microsoft Windows 8.1 Enterprise
oder
Microsoft Windows 10

32-bit (x86) oder 64-bit (x64)

32-bit (x86) oder 64-bit (x64)

32-bit (x86) oder 64-bit (x64)

Softwarevoraussetzungen

Oracle Java SE Runtime Environment 8 Update 131 (JRE) (x86)

Microsoft Internet Explorer 11.0 (x86)

Tests ausführen mit Apache Ant

Apache Ant 1.9.4

Linux-SystemumgebungPermanenter Link zu dieser Überschrift

Fabasoft app.test Agent

Betriebssystem

Prozessorarchitektur

Ubuntu 17.04

32-bit (x86)

Softwarevoraussetzungen

Oracle Java SE Runtime Environment 8 Update 131 (JRE)

Tests ausführen mit Apache Ant

Apache Ant 1.9.4

„Apple OS X“-SystemumgebungPermanenter Link zu dieser Überschrift

Fabasoft app.test Studio und Fabasoft app.test Agent

Betriebssystem

Prozessorarchitektur

Apple macOS Sierra 10.12

64-bit (x64)

Softwarevoraussetzungen

Oracle Java SE Runtime Environment 8 Update 131 (JRE)

Apple Safari 10.1

Tests ausführen mit Apache Ant

Apache Ant 1.9.4

ZusatzbedingungenPermanenter Link zu dieser Überschrift

  • Die notwendigen Hardware- und Softwareanforderungen für eine zukünftige Version dieses Produkts können von den Anforderungen der aktuellen Version abweichen.
  • Eine bestimmte Softwareproduktversion eines Drittherstellers, die in einem Fabasoft-Softwareprodukt integriert ist, wird von Fabasoft maximal solange produktseitig unterstützt als diese Softwareproduktversion vom Dritthersteller selbst unterstützt wird. Beispielsweise wird eine bestimmte Version eines integrierten Microsoft-Softwareprodukts nur maximal bis zu dem Datum von Fabasoft unterstützt, an dem die Microsoft „Extended Support Phase“ für diese Softwareproduktversion abläuft.
  • Softwareprodukte von Drittherstellern, die von Fabasoft-Produkten vorausgesetzt oder unterstützt werden, deren ordnungsgemäße Lizenzierung und Installation, die notwendigen Tests vor der Produktionsfreigabe sowie der entsprechende Herstellersupport sind nicht im Liefer- und Leistungsumfang enthalten und unterliegen daher insbesondere hinsichtlich ihrer Funktionalität, Funktionsweise oder Eigenschaften nicht der Gewährleistung durch Fabasoft. Fabasoft haftet nicht für Fehler oder Funktionsstörungen, welche durch Softwareprodukte von Drittherstellern und/oder solchen, die nicht im Liefer- und Leistungsumfang enthalten sind, verursacht werden.
  • Fabasoft-Softwareprodukte werden nur auf den jeweils angeführten Referenz-Systemumgebungen unterstützt und getestet. Zusätzlich zu den in den Referenz-Systemumgebungen angeführten Editions von Drittprodukten werden die im Kapitel „Unterstützte Editions von Drittprodukten“ angeführten Editions unterstützt, jedoch nicht getestet.

Unterstützte Editions von DrittproduktenPermanenter Link zu dieser Überschrift

Folgende Editions von Drittprodukten werden unterstützt. Explizit getestet werden nur die bei den Referenz-Systemumgebungen angeführten Editions.

  • Das Drittprodukt Microsoft Windows 7 SP1 wird in folgenden Editions unterstützt: Enterprise und Ultimate.
  • Das Drittprodukt Microsoft Windows 8.1 wird in folgenden Editions unterstützt: Pro und Enterprise.
  • Das Drittprodukt Microsoft Windows 10 wird in folgenden Editions unterstützt: Pro und Enterprise.

MinimalvoraussetzungenPermanenter Link zu dieser Überschrift

Prozessorarchitektur

Prozessor

Arbeitsspeicher

Festplattenspeicher

32-bit (x86)

1,6 GHz

1 GB

1 GB

64-bit (x64)

1,6 GHz

1 GB

1 GB